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Introduction 
 

Microsoft Excel is one of a number of spreadsheet applications that can be 

used for tabulation, calculation and graphing. In the sciences, the most 

common application of Excel will be for plotting graphs.  

 

This guide to Excel is divided into five sections:  

 

1. Entering and analysing data 

2. Plotting a chart 

3. Editing a chart 

4. Handling uncertainties  

5. Constructing formulae 

 

The first three sections of the guide lead the user through the steps required 

to process a set of data. The examples used are typically from the Higher 

Physics course but the processes are equally applicable to data obtained from 

any experiment where the fixed and measured variables give rise to numerical 

data. Instructions are given on how to produce a chart suitable for inclusion 

in the Researching Biology, Chemistry and Physics reports in the new Higher 

courses.  

 

Section 4 concerns the definitions of random, percentage and absolute 

uncertainties that are used in the physics courses. In Advanced Higher 

Biology and Chemistry Investigations, it may be useful to present standard 

deviation as an expression of uncertainty and so the use of Excel for this 

application is also described. 

 

Section 5 takes the user through the commonly used operators used for 

constructing formulae for inclusion in spreadsheets.  
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Introduction to Excel 2007 

 

When Excel 2007 is opened, this is what is seen:  

 

 
 

Active cell 

The cell with the black outline. Data are always entered into the active cell.  

 

Column letter 

Columns run vertically on a worksheet and each one is identified by a letter 

in the column header, eg the first column is column A. 

 

Formula bar 

Located above the worksheet, this area displays the contents of the active 

cell. It can also be used for entering or editing data and formulas. 

 

Name box 

Located next to the formula bar, the Name box displays the cell reference or 

the name of the active cell. 

 

Row number 

Rows run horizontally in an Excel 2007 worksheet and are identified by a 

number in the row header. 

 

Sheet tab 

Switching between worksheets is done by clicking on the sheet tab at the 

bottom of the screen. 

Active cell 

Name box Formula bar 
Column letter 

Row number 

Sheet tab 

Office button 

Ribbon 

http://spreadsheets.about.com/od/a/g/active_cell.htm
http://spreadsheets.about.com/od/d/g/data_definition.htm
http://spreadsheets.about.com/od/c/g/column_header.htm
http://spreadsheets.about.com/od/uvw/g/worksheet_def.htm
http://spreadsheets.about.com/od/c/g/column_header.htm
http://spreadsheets.about.com/od/f/g/Formula_bar_def.htm
http://spreadsheets.about.com/od/f/g/formula_defined.htm
http://spreadsheets.about.com/od/glossary/g/name_box_def.htm
http://spreadsheets.about.com/od/c/g/cell_ref_def.htm
http://spreadsheets.about.com/od/glossary/g/row_definition.htm
http://spreadsheets.about.com/od/r/g/row_head_def.htm
http://spreadsheets.about.com/od/uvw/g/worksheet_def.htm
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Office button 

Clicking on the Office button displays a drop-down menu containing a 

number of options, such as Open, Save, and Print. The options in the Office 

button menu are very similar to those found under the File menu in previous 

versions of Excel. 

 

Ribbon 

The ribbon is the strip of buttons and icons located above the work area in 

Excel 2007. The ribbon replaces the menus and toolbars found in ear lier 

versions of Excel. 

 

http://spreadsheets.about.com/od/no/g/office_button.htm
http://spreadsheets.about.com/od/r/g/Ribbon.htm
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Section 1: Entering and analysing data 
 

Working through this section allows you to produce a spreadsheet showing 

the data obtained from a physics experiment. The intensity of light from a 

lamp was measured as the distance of the sensor from the lamp was altered.  

 

Entering data, whether text or numerical, into a spreadsheet is a three-step 

process. The steps are: 

 

1. Click on the cell where you want the data to go. 

2. Type your data into the cell. 

3. Press the Enter key on the keyboard or click on another cell with the 

mouse. 

 

If you make a mistake, the Esc key cancels the data entry. As in all Microsoft 

products, pressing Ctrl-Z will undo the last process. 

 

Entering the independent variable 

 

When Excel is opened this is what will be seen.  

 

 
 

The independent variable (what is changed in an experiment) should always 

be placed into the first column (column A). This ensures that the independent 

variable will be plotted on the x-axis. The dependent variable (what is 

measured in an experiment) should always be placed into the second c olumn 

(column B). This ensures that the dependent variable will be plotted on the y-

axis. 

 

http://spreadsheets.about.com/od/d/g/data_definition.htm
http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/c/g/cell_definition.htm
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Entering a column heading 

 

The independent variable in this experiment is the distance of the light sensor 

from the lamp, measured in centimetres. The column heading (Distance from 

lamp/cm) is entered into the spreadsheet in cell A1 using the three steps given 

above. Input the distance from lamp data into column A starting at cell A2.  

 

The spreadsheet will now look like this:  

 

 
 

Changing the column heading 

 

The column heading is too large for the column. There are two ways to solve 

this problem depending on whether the spreadsheet has only a few columns or 

a larger number of columns.  

 

If there are only a few columns, the column width can be enlarged to fit the 

text by placing the cursor on the boundary between the A and B cells. The 

cursor will change from a white cross to a black cross with arrowheads on the 

horizontal bar. Double click and the column width will automatically change 

to fit the width of the text. 

 

The spreadsheet will now look like this:  

 

 
 

Press Ctrl-Z and the heading will go back to the way it was.  

 

Should the finished spreadsheet contain a large number of columns, this type 

of formatting will result in a very wide spreadsheet that does not easily fit  
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onto an A4 page. It should only be used in spreadsheets with a small number 

of columns. The following method is very useful when the spreadsheet has a 

larger number of columns. 

 

Changing the text width to fit the column width  

 

1. Click on the A cell. 

2. Click on the Home tab. 

3. Click on Wrap text, Align top and Align centre in the text alignment 

window. 

 

Or 

 

1. Click on Alignment and the Format Cells window will appear.  

 

 
 

2. In the Horizontal cell, pull down the menu and select Centre.  

3. In the Vertical cell, pull down the menu and select Top. 

4. In the Text control options, click on Wrap text, and a small tick will 

appear in the box. 

5. Click on OK  
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The spreadsheet will now look like this:  

 

 
 

This style of column heading is very useful where the spreadsheet has a larg e 

number of columns and may have to be imported into another document when 

preparing a report. 

 

Entering the dependent variable 

 

The dependent variable in this experiment was the intensity of light measured 

in lux. The heading, Intensity of light/lux, should be entered into cells B1 and 

C1, and the text width adjusted to fit the column width as before. The 

experiment was repeated and the two sets of intensity data should be entered 

into columns B and C, starting in cells B2 and C2.  

 

The spreadsheet will now look like this: 
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Entering an Excel function 
 

Excel is very useful for performing functions on data. The formula is inserted 

in the formula bar. An equals sign must be used before every function and 

formula to tell Excel that it must perform a function. An example is the use of 

the average function. 

 

In order to calculate the average intensity of light, the average function may 

be used. Select cell D1 and enter the heading ‘Average intensity of light/lux’. 

Adjust the text width to fit the column width.  

 

1. Select cell D2. 

2. Type ‘=average(’. 

3. Click onto cell B2, hold down and drag over to cell C2.  

4. B2 and C2 will now have a moving dotted border, and the formula will 

now read =average(B2:C2. 

5. Close the bracket to give =average(B2:C2) and the moving border will 

disappear. 

6. Press Enter and the answer 555 will appear in cell D2. Whenever cell 

D2 is selected, the function will be shown in the Formula bar (to the 

right-hand side of the equals sign). 

 

Copying a cell 

 

There are two ways to copy cells, depending on where the information is to 

be placed. 

 

Copying the cell to a non-adjacent cell 

To copy the average function in cell D2 to cell D7.  

 

1. Select cell D2. 

2. Click on the Home tab. 

3. Choose Copy. The cell will now have a moving dotted border.  

4. Select the cell where the information is to be placed, ie cell D7. 

5. Choose Paste. 

6. The information from cell D2 will be pasted into cell D7 and the answer 

80 will appear. 

 

Copying a cell to adjacent cells 

To copy the average function in cell D2 to cells D3 to D7.  

 

1. Select cell D2. 

2. Move the cursor to the bottom right-hand corner of the cell and the 

cursor will change from a white cross to a black cross.  
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3. Once the cursor has changed, hold and drag it down the screen until 

cells D3 to D7 are edged in grey.  

4. Release the cursor. The answers will  appear in each of the cells, and the 

cursor will change back to a white cross.  

 

The spreadsheet will now look like this:  

 

 
 

 

Inserting a column 

 

After inputting your data, you may wish to perform a function on the 

independent variable (data in column A).  For example, the relationship 

between light intensity and distance is an inverse-square relationship. 

 

1/distance
2
 (1/d

2
) is calculated from the independent variable. When plotting 

a graph (known as a chart in Excel), the independent variable (or any dat a 

resulting from its use) should always be placed to the left -hand side of the 

data for the dependent variable. It will be necessary to insert a column 

between columns A and B. 

 

1. Click on the B cell. The whole of column B will be highlighted.  

2. Click on the Home tab. 

3. Click on Insert. 

4. An empty column will have been inserted between the former columns 

A and B. The new column will have become column B and the former 

columns B, C and D will have been shifted one letter to the right.  

 

2distance

1
light  ofIntensity 
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The spreadsheet will now look like this: 

 

 
 

Entering a formula in the column heading 

 

The formula 1/d
2
 and unit cm

–2
 are to be used as the column B heading. The 

column heading will be input as (1/d
2
)/cm

–2
. The brackets around the term 

1/d
2
 are there to make the heading more legible, as 1/d

2
/cm

–2
 is not very clear.  

 

1. Select cell B1. 

2. Type in (1/d2)/cm–2. 

3. In the Formula bar, highlight the first number 2 using the cursor.  

4. Click on the Home tab. 

5. Open the Format Cells window from the Font panel (small icon on the 

bottom left-hand corner). 

 

 
 

6. Click on Superscript and a small tick will appear beside the word.  

7. Click on OK and the column heading will now read (1/d
2
)/cm–2, 

although it will not have changed in the Formula bar. 

8. In the Formula bar, highlight the –2 using the cursor. 

9. Open the Format Cells window as before. 
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10. Click on Superscript and a small tick will appear beside the word.  

11. Click on OK and the column heading will now read (1/d
2
)/cm

–2
, 

although it will not have changed in the Formula bar. 

 

The spreadsheet will now look like this:  

 

 
 

Entering a formula 

 

Column B is to be used to calculate the value of 1/d
2
 for each of the values of 

distance in column A. In order to do this a formula must be entered in the 

column B cells.  

 

1. Select cell B2. 

2. Type in ‘=1/(A2^2)’. The hat symbol (^) is entered by pressing the Shift 

key and the number 6 key together. It means ‘to the power of’.  

3. Press Enter and the answer 0.0016 will appear in cell B2.  

4. Copy the formula to cells B3 to B7 using the given method for copying 

a cell to adjacent cells. 

 

The spreadsheet will now look like this: 
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Formatting numbers 

 

The numbers in column B have a range of decimal places. They may be 

expressed in scientific notation by doing the following.  

 

1. Click on the grey B cell to highlight the whole of column B.  

2. Click on the Home tab. 

3. Open the Format Cells window from the Number panel (small icon on 

the bottom left-hand corner). The window looks like this:  

 

  
 

4. Go to the Category options and click on Scientific. Click the down 

arrow once to change the number of decimal places to 1. 

5. Click on OK and the spreadsheet will now look like this:  

 

 
 

The E stands for ‘times 10 to the power of’. If any of the data were very 

small it would be possible to enter them into the spreadsheet using this 

notation, for example a wavelength of 720 nm would be input as 720E-09. 
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When scientific notation is used in the spreadsheet, it becomes difficult to see 

any trends in the data. In the example being used, the trend becomes easier to 

spot if the cells are formatted to show four decimal places. The ce lls are 

formatted using the following instructions. 

 

1. Click on the grey B cell to highlight the whole of column B.  

2. Open the Format Cells window in the Number panel.  

3. Click on Number from the Category options.  

4. Click the upwards arrow three times to change the number of decimal 

places to 4. 

5. Click on OK and the spreadsheet will look like this:  

 

 
 

It is now clear to see that as (1/d
2
)/cm

–2
 is doubled the average intensity of 

light/lux approximately doubles, suggesting a linear relationship.  
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Section 2: Plotting a chart 
 

Selecting data in non-adjacent columns 

 

In Excel, graphs are known as charts. From the inputted data, a chart of 

average light intensity/lux against (1/d
2
)/cm

–2
 is to be plotted. The data for 

the chart are in columns B and E.  

 

1. Click on the B cell. 

2. Hold down the Control key (Ctrl) and click on the E cell.  

 

The spreadsheet will now look like this:  

 

 
 

Selecting the chart type 

 

The type of chart is selected from the Insert tab, as shown below.  
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Clicking on the small icon in the bottom left-hand corner of the Charts panel 

reveals the Format Chart window. 

 

 
 

The chart types offered in Excel include column, bar, line, pie and scatter. 

There may be occasion to use all of these types of graph in producing reports 

for Higher and Advanced Higher courses. The most common types, however, 

are likely to be scatter graphs.  

 

Plotting data as a scatter chart 

 

1. With columns B and E still highlighted, click on the Insert tab.  

2. Click on Scatter, the Scatter chart menu will appear.  

 

 
 

The Scatter chart type plots the data points but does not automatically plot a 

best-fit line. For some applications (for example, Outcome 3 in Higher 

Physics) students must hand draw the best-fit line. For other applications, 

however, a best-fit line can be added as a trendline. 
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3. Click on the top left chart from the Scatter chart menu and your chart 

will appear in a new window. The chart tools of Design, Layout and 

Format will appear on the ribbon and look like this:  

 

 
 

Changing the chart titles 

 

Excel automatically titles the chart with the column heading for the 

dependent variable. To change the chart title, click on it and then right -click. 

The following window will appear. 

 

 
 

1. Click on Edit Text. 

2. Delete the contents and type in ‘Variation of average light intens ity 

with (1/d2)’. 

3. Highlight the 2 and right-click, select Font and tick the superscript box 

as before. 
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The chart will now look like this: 

 

 
 

To label the axes, click on the chart and select the Layout tab.  

 

1. Select Axis Titles on the Layout panel.  

2. Select Primary Horizontal Axis Title from the drop-down menu. 

3. Select Title Below Axis as shown below. 

 

 
 

4. Click on Title Below Axis and the chart will look like this:  
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5. Click on the Axis Title cell, delete the contents and type in ‘(1/d2)/cm–

2’. Highlight and format the 2 and the –2 as before. 

6. Select Axis Titles on the Layout panel.  

7. Select Primary Vertical Axis Title from the drop-down menu. 

8. Select Rotated Title as shown below. 

 

 
 

9. Click on the Axis Title cell, delete the contents and type in I/lux.  

 

The chart will now look like this: 

 

 
 

Changing the chart gridlines 

 

There are two types of gridlines: 

 

1. major gridlines 

2. minor gridlines. 
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For example, a scale increases in steps of 10 units with subdivisions every 5 

units. If only major gridlines were chosen then there would be gridlines every 

10 units. If major and minor gridlines were chosen then there would be 

gridlines every 5 units. Major gridlines may be used when the user is trying 

to find a trend, but if any information is to be read off the chart then minor  

gridlines must also be shown. In this example major and minor gridlines will 

be applied to both axes. 

 

1. Click on the chart area and select the Layout tab.  

2. Select Gridlines on the Axes panel.  

3. Select Primary Horizontal Gridlines from the drop-down menu. 

4. Select Major & Minor Gridlines as shown below. 

 

 
 

The chart will now look like this: 

 

 
 

5. Click on the chart area and select the Layout tab.  

6. Select Gridlines on the Axes panel.  

7. Select Primary Vertical Gridlines from the drop-down menu. 

8. Select Major & Minor Gridlines. 

 



SECTION 2 

23 GUIDE TO EXCEL FOR THE SCIENCES (H, AH SCIENCE) 

 

© Learning and Teaching Scotland 2011 

The chart will now look like this: 

 

 
 

Changing the chart legend 

 

The legend on a chart is similar to a key. It is used to distinguish between 

sets of data when they are plotted on the same chart. If there is only one set 

of data, as in the example used here, it is best to remove the legend. If you 

plot more than one curve on the same chart the legends will show the column 

headings for the dependent data plotted. 

 

To remove the legend, click on the legend, right -click and select Delete. 

 

Changing the chart data labels 

 

The Data labels option allows the user to show the values of each point 

beside it on the chart. This option can be useful if there is more than one set 

of data plotted on the same chart. To show the data labels:  

 

1. Click on the chart area and select the Layout tab. 

2. Select Data Labels on the Labels panel. 
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3. Select Right display, as shown below. 

 

 
 

The chart will now look like this: 

 

 
 

When there is only one set of data, the data labels are not required. To 

remove them, press Ctrl-Z. 

 

Selecting the chart location 

 

The Chart Location option allows the user to choose where the chart is to be 

placed. The chart may be placed on top of the existing spreadsheet or it may 

be placed on a sheet of its own. It is best to put the chart onto a new sh eet if 

it is to be imported into a Word document.  

 

1. Click on the chart area and select the Design tab.  
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2. Click on Move Chart Location on the far left of the ribbon. The Move 

Chart window will appear. 

 

 
 

3. Click on the dot beside ‘New sheet’.  

4. Click in the cell beside it and type in the name of the new sheet, ‘Light 

intensity and distance’. 

5. Click on OK and the graph will appear on a new sheet and look like 

this: 

 

 
 

Changing the page set-up 

 

Excel automatically plots the chart using the landscape page set -up. This 

results in a long x-axis and a short y-axis. In some situations it may be 

advantageous to have the chart set-up so that the x-axis is short and the y-axis 

is long. This is easily changed. 

 

1. Click on the Page Layout tab. 

2. Select Orientation.  



SECTION 2 

GUIDE TO EXCELFOR THE SCIENCES (H, AH SCIENCE) 26 

 

© Learning and Teaching Scotland 2011 

3. Select Portrait as shown below. 

 

 
 

The chart in this example is best plotted with a long x-axis. Select Landscape 

from the menu as shown below and the chart will return to its previous form.  
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Section 3: Editing a chart 
 

Edits to a chart can be made from the Layout tab. The axes can be edited by 

selecting Axes, then either axis. To edit the x-axis, for example, select 

Primary Horizontal Axis and then More Primary Axis Options as shown 

below.  
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The following window will appear: 

 

 
 

From this window, a number of edits can be made. Excel automatically 

selects the axis scale. To change the scale to make it easier to read:  

 

1. Click on Fixed beside Minimum and enter 0 in the box.  

2. Click on Fixed beside Maximum and enter 0.002 in the box.  

3. Click on Fixed beside Major unit  and enter 0.005 in the box. 

4. Click on Fixed beside Minor unit and enter 0.0001 in the box.  

5. Click on Close and the chart will now look like this:  

 

 
 

The scale on the y-axis can be changed in the same way from the Format Axis 

window by selecting the Primary Vertical Axis and More Vertical Axis 

Options as above. Change the Axis Options as follows.  

 

1. Click on Fixed beside Minimum and enter 0 in the box.  
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2. Click on Fixed beside Maximum and enter 600 in the box.  

3. Click on Fixed beside Major unit and enter 50 in the box. 

4. Click on Fixed beside Minor unit and enter 25 in the box.  

5. Click on Close and the chart will now look like this:  

 

 
 

From the Format Axis window, selected as above, the format of the axis 

numbers can be changed. Click on number and the following wind ow will 

appear: 

 

 
 

This is the same as the one used to format the numbers on the spreadsheet. 

The numbers on the x-axis and the y-axis have already been formatted.  
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From the Format Axis window, the axis line style can also be changed. To 

make the axis line thicker click on Line Style and increase the line width to 

3pt using the upwards arrow. The window will look like this:  

 

  
 

Click on close and the chart will look like this:  
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The y-axis thickness can be changed in the same way from the Primary 

Vertical Axis Options Tab. Change the y-axis to 3pt and the chart will look 

like this: 

 

 
 

The axis labels can be changed by right -clicking on the label. The following 

window will appear: 
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From this window, the font, font size, colour and alignment can be c hanged, 

if required. By right-clicking on the chart title, the same options for editing 

are available. 

 

 
 

The data points can be edited by right -clicking on one of the points and 

selecting Format Data Series. 
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The following window will appear: 

 

 
 

To change the data marker from the default diamond shape to a cross, select 

Marker Options, click the box beside Built -in and the drop-down menu of 

Type becomes available as shown below. 
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Select the fourth marker down and click on Close. The chart will no w look 

like this: 

 

 
 

To make the crosses more distinct, the colour should be changed from the 

default. Right-click on one of the crosses, select Format Data Series and 

select Marker Line Colour. Click on the box beside Solid Line and the Colour 

drop-down menu will become available. Select black and press Close. The 

chart will now look like this: 

 

 
 

For Higher Physics Outcome 3, the finished chart must be printed and a best -

fit line hand drawn. For other applications, such as an Advanced Higher 

Investigation report, a best-fit line can be drawn using Excel as follows. 

 

1. Right-click on one data point. 
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2. Select Add Trendline and the following window will appear:  

 

 
 

3. Select Linear. 

4. Click on Close and the chart will now look like this:  

 

 
 

It may be useful to display the equation of the line on the chart. From the 

Trendline Options window click on the box beside Display Equation on 

Chart.  
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The chart will now look like this: 

 

 
 

It should take a novice about 30 minutes to follow the instructions in this 

material, but with practice it is possible to produce a chart like the one shown 

above in about 5 minutes. 
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Section 4: Handling uncertainties 
 

When repeat experiments have been carried out, functions in the Excel 

spreadsheet can be used to correct for control,  blank or background values 

and to calculate means and uncertainties. 

 

The spreadsheet below shows a sample set of student results from an 

experiment repeated five times. The experiment involved the counts of 

gamma radiation measured through various thicknesses of lead. This data can 

be used in various ways to demonstrate handling uncertainties.  

 

 
 

To keep the spreadsheet compact, the cells containing identical column 

headings can be merged by dragging the cursor from cell B1 to F1 while 

making sure that all five cells are highlighted. Select the Home tab and click 

on Merge and Centre on the Alignment panel. The following window will 

appear: 
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Click on OK and the spreadsheet will now look like this:  

 

 
 

From the Home tab, the column width can be reduced by selecting Format in 

the Cells panel. Select Colum Width as shown below.  

 

 
 

The following window will appear: 
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Enter 8.0 in the Column Width box and click OK. The spreadsheet will now 

look like this: 

 

 
 

In this experiment, the background radiation count was 30 counts per minute. 

This value will be used to correct the count rate.  

 

Select cell G1 and type the heading Corrected count rate/counts per minute. 

Highlight cells G1 to K1 and merge as before.  

 

1. Select cell G2 and enter the formula ‘=B2-30’. 

2. Copy the formula to cells G2 to G6.  

3. Repeat for cells H2 to H6, I2 to I6, J2 to J6 and K1 to K6.  

4. Adjust the cell width to 8.0 as before. 

 

The spreadsheet will now look like this:  

 

 
 

The mean corrected count rate can be calculated as follows.  

 

1. Select cell L1. 

2. Enter the heading ‘Mean corrected count rate/counts per minute’.  

3. Align the heading Top and Centre from the Alignment Panel.  

4. Select Wrap Text as before and manually adjust the column width as 

before. 

5. Select cell L2 and enter’ =average(‘.  
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6. 6. Click and drag on cell G2 to cell K2; the five cells will have a 

moving dotted border as shown below. 

 

 
 

7. Press Enter and the number 823.6 will appear in cell L2.  

8. Copy the formula to cells L3 to L6. 

9. Use the Format Cells Number window to set the number of decimal 

places to zero as before. 

 

The spreadsheet will now look like this:  

 

 
 

Calculating uncertainties 

 

There are numerous ways to reflect the uncertainty in a set of data. 

Uncertainty is the margin of error in a particular measurement and is stated 

by giving a range of values likely to contain the true value. This can be given 

as ± values or as error bars on a graph.  

 

In Higher Physics, the approximate random uncertainty in the mean value is 

calculated using the formula:  

 

readings ofnumber 

reading minimum -reading maximum
yuncertaint random   

 

Excel does not have a specific function to calculate random uncertainty but it 

can be calculated using a formula created from other Excel functions. It is 

calculated using the formula:  

 

random uncertainty = (MAX(Array) – MIN(Array))/COLUMNS(Array) 
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In the Array bracket the user needs to tell Excel which cells to use. In this 

case it is cells G2 to K2 inclusive (written as G2:K2). Care must be taken 

with the positioning of the brackets.  

 

1. Select cell M1. 

2. Enter the column heading ‘Random uncertainty in the mean corrected 

count rate/counts per minute’. 

3. Select cell M2 and type ‘=MAX(’. 

4. Click and hold on cell G2 and drag across to cell K2.  

5. Close the array bracket and the formula will look like this: 

=MAX(G2:K2). 

6. Type in the rest of the formula shown above inserting G2:K2 each time 

the word ‘Array’ appears. 

7. Press Enter and cell M2 will display the answer 15.4.  

8. Copy the formula to cells M3 to M6. 

9. Use the Format Cells Number window to set the number of decimal 

places to zero and the spreadsheet will look like this:  

 

 
 

The approximate random uncertainty can be expressed as a percentage of the 

mean. This is done using the following formula.  

 

mean value

100 mean in they uncertaint random
yuncertaint percentage


  

 

1. Select cell N1. 

2. Enter the column heading ‘Percentage uncertainty in the mean corrected 

count rate’. 

3. Click on cell N2 and type in the formula ‘=(M2/L2)*100’. 

4. The answer 1.868933…will appear in cell N2.  

5. Copy the formula to cells N3 to N6.  
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6. Use the Format Cells Number window to change the number of decimal 

places to zero. Columns L, M and N will look like this:  

 

 
 

The manufacturer of the lead states that the thickness has an uncertainty of 

±5%. This percentage will be used to calculate the absolute uncertainty in the 

thickness of the lead. The absolute uncertainty is calculated using the 

formula: 

 

100

reading yuncertaint percentage
yuncertaint absolute


  

 

1. Select cell B2. Go to Insert Cells on the Home tab.  

2. Select Insert Sheet Columns from the drop-down menu. 

3. Repeat steps 1 and 2 and two new columns will be inserted.  

4. Select cell C1 and enter the heading ‘Percentage uncertainty in the 

thickness of lead’. 

5. Enter the value 5 into cells C2 to C6. 

6. Select cell B1 and enter the heading ‘Absolute uncertainty in the 

thickness of lead/mm’. 

7. Select cell B2 and enter the formula =(C2/100)*A2.  

8. The answer of 0.0 will appear in cell B2.  

9. Copy the formula into cells B3 to B6. 
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10. Use the Format Cells Number window to set the number of decimal 

places to 1 and the first three columns of the spreadsheet will look like 

this: 

 

 
 

It is now possible to plot an XY scatter chart of mean corrected count rate 

(column O) against the thickness of lead (column A). The chart should be 

placed on a new sheet entitled ‘Half-thickness’. The x-axis scale settings 

should be set to Maximum 26, Minimum 0, Major unit 1, Minor unit 0.25. 

The y-axis scale settings should be set to Maximum 850, Minimum 0, Major 

unit 50, Minor unit 5. The x-axis and y-axis Major gridlines can be made 

thicker than the default settings to make the chart more legible. This is 

achieved from the Format Major Gridlines window for both Horizontal and 

Vertical axis and choosing a black solid l ine as shown below. 

 

 



SECTION 4 

GUIDE TO EXCELFOR THE SCIENCES (H, AH SCIENCE) 44 

 

© Learning and Teaching Scotland 2011 

The data markers have been made larger to make them clearer. This is 

achieved from the Format Data Series window, increasing the Marker size as 

shown below. 

 

 
 

The Page set-up of the chart is also changed to Portrait to allow the y-axis 

scale to be enlarged from Excel’s original choice.  
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The chart should look like the one below. 

 

 
 

Error bars can be plotted on a chart based on the uncertainty in the readings 

or in the data. Error bars are required at Advanced Higher Physics and cou ld 

be useful when presenting data in Advanced Higher Chemistry and Biology 

Investigation reports. Excel can plot error bars for each data point on a chart. 

There are three options for plotting error bars:  

 

1. fixed percentage error bars  

2. fixed value error bars 

3. custom error bars. 
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Fixed percentage error bars can be used in this example as the manufacturer 

gave the percentage uncertainty in the thickness of the lead as ±5%.  

 

1. Double click on the chart and select the Layout tab.  

2. Click on Error bars and a drop-down menu will appear. 

3. Select Error Bars with Percentage, the default value is 5%.  

4. Excel will automatically place both vertical and horizontal error bars. 

To remove the vertical bars, select Y Error Bars from the Current 

Selection panel on the top left-hand corner, as shown below. 

 

 
 

5. Select Error Bars from the Analysis panel and select None to remove 

the vertical error bars. 

6. The chart will now display error bars as shown on the next page.  

7. If a percentage value other than 5 is required, select More Error Bar 

Options from the Error Bar menu and the following window will appear:  

 

 
 

Any value for percentage error can be typed into the box shown in the 

window above. 
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A fixed error can also be used to create error bars in a chart. For example, if 

the student carrying out the experiment believes that the uncertainty in the 

thickness of the lead is ±1mm: 

 

1. Select More Error bar options as before. 

2. Select Fixed Value and enter 1.0 as shown below.  

3. Click on Close and the chart will display error bars with the fixed val ue 

of 1 mm as shown below. 
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Mean and standard deviation 

 

In an experiment where replicate measurements have been made, it is often 

useful to present the mean of the data and the uncertainty expressed as a 

standard deviation. Standard deviation is a measure of how closely the data 

are clustered around the mean. The smaller the standard deviation, the more 

closely the data are clustered around the mean.  

 

The equation for standard deviation is as follows:  

 

 
1

2







n

xx
s  

 

where x  is the mean, x is the value of a data point and n is the number of 

data points. Excel uses the function STDEV to calculate the standard 

deviation of a data series. 

 

A sample set of data is shown below for the measured lifetime in hours of a 

number of lightbulbs. 

 

 
 

To calculate the mean and standard deviation of the data:  

 

1. Select cell E2. 

2. Type in ‘=AVERAGE(’. 

3. Select cells A2 to D2 and press Enter. 

4. The number 823.25 will appear in cell E2. 

5. Select cell F2. 

6. Type in ‘=STDEV(’. 

7. Select cells A2 to D2 and press Enter. 

8. The number 30.269… will appear in cell F2.  

 

Expression of the standard deviation as a percentage of the mean is known as 

a relative standard deviation or a coefficient of variation. The relative 

standard deviation can be calculated from the da ta shown. 

 

1. Select cell G2. 
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2. Type in ‘=(F2/E2)*100’ and press Enter.  

3. The number 3.676… will appear in cell G2. 
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Section 5: Constructing formulae 
 

Arithmetic operators 

 

The four basic arithmetic operators used in the construction of a formula are 

shown below. 

 

Mathematical operation Excel operator Example 

Addition + (plus sign) 3+4  

Subtraction, negation – (minus sign) 9–2 or –2 

Multiplication * (asterisk) 6*7 

Division / (forward slash) 12/2 

 

These operators are used with brackets to create simple formulae, as seen 

above. Excel follows the BODMAS order of operations – brackets before 

division, multiplication, addition and subtraction. Excel always carries out 

calculations placed inside brackets first, so great care must be taken with the 

positioning of brackets. Multiple brackets are colour coded in Excel to help 

you remember to close brackets. 

 

Example 1 

 

The data in the spreadsheet below are to be used to calculate the acceleration 

of an object (a) using the formula: 

 

( )


v u
a

t
 

 

 
 

1. On a piece of paper, write the formula using the Excel operators, but 

without brackets. The formula becomes a=v–u/t. 
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2. Brackets must be placed around the change in velocity to tell Excel to 

calculate it first and then divide by the time. The formula reads a=(v–

u)/t. 

3. Cell A2 contains the value for u, cell B2 contains the value for v, and 

cell C2 contains the value for t. The formula becomes a=(B2-A2)/C2. 

4. Select cell D2, type in the formula (a=(B2-A2)/C2) and press Enter. 

5. The answer 2 will appear in cell D2. 

 

Hat operator 

The ^ (hat) operator is used to raise the power of a number. It is located on 

the number 6 key. 

 

Example 2 

 

The data in the spreadsheet below are to be used to calculate s using the 

formula: 

 

21

2
 s ut at  

 

 
 

1. On a piece of paper, write the formula using the Excel operators only, 

changing the half to 0.5. A multiplication operator must be placed 

between all of the terms that are to be multiplied. The formula becomes 

s=u*t+0.5*a*t^2. 

2. Insert brackets around the u*t and the 0.5*a*t^2. The formula become 

s=(u*t)+(0.5*a*t^2). 

3. Cell A2 contains the value for u, cell B2 contains the value for a, and 

cell C2 contains the value for t. The formula becomes 

s=(A2*C2)+(0.5*B2*C2^2). 

4. Select cell D2, type in the formula =(A2*C2)+(0.5*B2*C2^2) and  press 

Enter. 

5. The answer 56 will appear in cell D2. 

 



SECTION 5 

53 GUIDE TO EXCEL FOR THE SCIENCES (H, AH SCIENCE) 

 

© Learning and Teaching Scotland 2011 

SQRT function 

 

The SQRT(number) function calculates the square root of the number placed 

in the brackets. Excel is not sensitive to upper or lower case lettering. It will 

automatically change any lower case letters in a function to upper case 

letters, for example SqRt will be changed to SQRT. 

 

Example 3 

 

A student wishes to calculate the velocity of an object (v) using the formula:  

 

21

2
kE mv  

 

After rearranging, the formula becomes:  

 

2
 kE

v
m

 

 

The data to be used are shown in the spreadsheet below.  

 

 
 

1. On a piece of paper, write the formula using the Excel operators and 

functions. The formula becomes v=SQRT(2*Ek/m). 

2. Insert brackets around the 2*Ek. The formula becomes 

v=SQRT((2*Ek)/m). The outer brackets are part of the SQRT() function. 

The inner brackets tell Excel to calculate 2*E k before it divides by m.  

3. Cell A2 contains the value for Ek and cell B2 contains the value for m. 

The formula becomes v=SQRT((2*A2)/B2). 

4. Select cell D2, type in the formula =SQRT((2*A2)/B2) and press Enter.  

5. The answer 8 will appear in cell D2. 

 

PI function 

 

The mathematical constant  is used in many physics calculations. Excel does 

not have a symbol for  but has a function PI(). The PI() function returns a 

value of  accurate to 15 digits. When using the PI() function, nothing is 

placed inside the brackets.  
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Example 4 

 

A student has to calculate the period of a simple pendulum ( T) using the 

formula: 

 

2
l

T
g

 

 

The required data are shown in the spreadsheet below.  

 

 
 

1. On a piece of paper, write the formula using the Excel operators and 

functions. The formula becomes T=2*PI()*SQRT(l/g).  

2. Cell A2 contains the value for l and cell B2 contains the value for g. 

The formula becomes T=2*PI()*SQRT(A2/B2). 

3. Select cell D2, type in the formula =2*PI()*SQRT(A2/B2) and press 

Enter. 

4. The answer 1.4185 will appear in cell D2.  

 

AVERAGE function 

 

The AVERAGE (number 1, number 2,…) function is used to calculate the 

arithmetic mean of a series of numbers. The numbers may be placed directly 

into the function or if a large amount of data is being analysed, the array of 

data may be entered.  

 

Example 5 

 

A student wants to find the mean of the readings shown in the spreadsheet 

below. 

 

 
 

1. Select cell F2 and type in ‘=AVERAGE(’. 

2. Click on cell A2, hold down the mouse button and drag over to cell E2.  
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3. Release the mouse button and close the bracket to give 

=AVERAGE(A2:E2). 

4. The answer 4.4 will appear in cell F2.  

 

The main advantage of following this method is that the user does not have to 

retype all of the data, risking typing errors in the process. The array of cells 

A2:E2 is linked to the formula. If the formula is copied to cell F3, the array 

A3:E3 would be used in the calculation. 

 

Trigonometric functions 

 

The six basic trigonometric functions are shown in the table below.  

 

Trigonometric function Excel function 

sin SIN (angle in radians) 

cos COS (angle in radians) 

tan TAN (angle in radians) 

sin
–1

 ASIN (angle in radians) 

cos
–1

 ACOS (angle in radians) 

tan
–1

 ATAN (angle in radians) 

 

Excel uses radians as its unit for angles. There are, however, two very useful 

conversion functions available. 

 

Conversion  Excel function 

Degrees to radians RADIANS (angle in degrees) 

Radians to degrees DEGREES (angle in radians) 
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Example 6 

 

A student is to calculate the refractive index (n) of a material using the 

formula: 

 

sin

sin




 a

m

n  

 

and the data given in the spreadsheet below. 

 

 
 

1. On a piece of paper, convert the 30 degrees to radians using the 

conversion function given above. The formula becomes 

sina=RADIANS(a). 

2. Insert the sin function into the formula. The formula now reads 

sina=sin(RADIANS(a)). 

3. Cell A2 contains the value for a. The formula becomes 

sina=sin(RADIANS(A2)). 

4. Select cell C2, type in the formula =sin(RADIANS(A2)) and press 

Enter. 

5. The answer 0.5 will appear in cell C2. 

6. Copy the formula to cell D2 and the answer 0.37461 will appear.  

7. The formula for refractive index is:  

 

sin

sin






a

m

n  

 

8. Select cell E2, type =C2/D2 and press Enter. 

9. The answer n=1.3347… will appear in cell E2.  

 

Example 7 

 

A student knows the refractive index of a semicircular prism and the angle of 

incidence of a ray of light within the prism m. The student wants to predict 

the angle of refraction of the ray of light as it passes from the prism into the 

air. 
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For angles less than the critical angle, the predicted angle of refraction is 

calculated using the formula:  

 

 1sin sin a mn  

 

 
 

On a piece of paper write the formula to calculate sinm in radians: 

 

a=SIN(RADIANS(m)) 

 

1. Multiply the formula by n to give a=n*SIN(RADIANS(m)). 

2. Take the inverse sin of the formula, giving 

a=ASIN(n*SIN(RADIANS(m))). 

3. Cell A2 contains the value for m, and cell B2 contains the value for n. 

The formula now becomes a=ASIN(B2*SIN(RADIANS(A2))). 

4. If this formula were used in cell C2 it would return an answer of 

0.73420…This is the correct angle but it is measured in radians. Use the 

DEGREES() function to convert the answer to degrees, giving the 

finished formula of a=DEGREES(ASIN(B2*SIN(RADIANS(A2)))).  

5. Select cell C2 then type in 

=DEGREES(ASIN(B2*SIN(RADIANS(A2)))) and press Enter. Be very 

careful with the brackets. 

6. The answer of 42.0670648…will appear in cell C2.  

 

To insert symbols as shown in the headings in the example above, select the 

Insert tab and select the Symbol panel on the far left. A number of common 

symbols can then be inserted into the heading.  

 

Logarithmic functions 

 

Excel has four logarithmic functions shown in the table below. 

 

Logarithmic function Excel function 

log10n LOG10(number) 

logxn LOG(number, base) 

ln N LN(number) 

exp EXP(number) 
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Example 8 

 

1. Entering =LOG10(1000) would return an answer of 3.  

2. Entering =LOG(4,2) would return an answer of 2. 

3. Entering =LN(5) would return an answer of 1.60944… 

4. Entering =EXP(1) would return an answer of 2.7182..  

5. Entering =EXP(LN(5)) would return an answer of 5.  

 

These functions are not required at Higher but could be used at Advanced 

Higher in physics only. 


